Лабораторная работа №3 частотный анализ типовых звеньев



Скачать 332.79 Kb.
страница3/4
Дата13.01.2013
Размер332.79 Kb.
ТипЛабораторная работа
1   2   3   4

Внимание. Для правильного определения фазовой задержки отставание выходного сигнала относительно входного следует измерять после окончания переходного процесса, обусловленного подачей синусоиды на апериодическое звено. Это значит, что задержка должна измеряться по времени пересечения сигналами нулевого уровня на втором, третьем или еще более поздних периодах, в зависимости от частоты подаваемого на звено сигнала генератора. Так, на рис.2.12. частота генератора относительно низкая, поэтому запаздывание можно измерять уже в начале второго периода, поскольку переходный процесс апериодического звена при постоянной времени равной Т = 0.25 сек, длится меньше секунды.

Переходный процесс может быть сдвинут влево и убран с экрана осциллографа, если в настройках выбрать начальный момент моделирования Start равным – 10 - 100 сек, а в настройках осциллографа начальное значение горизонтальной оси принять равной 0.

Вспомогательный усилитель используется для поддержания амплитуды входного сигнала, подаваемого на осциллограф примерно такой же величины, что и значение выходного. Это упрощает измерение запаздывания и повышает точность измерений.




2. Провести измерение и вычисление значений частотных характеристик. Установить значения параметров апериодического звена k = 0.2, k = 1.0 и k = 5 постоянную времени Т = 0.25 сек (рис 2.13)



Рис. 2.13. Задание параметров апериодического звена
Проверить, что амплитуда синусоиды, генерируемой генератором, равна 1, и установить начальную частоту равной 0.1 рад/сек .



Рис.2.14. Задание частоты (Frequency) и амплитуды синусоиды генератора
В свойствах моделирования (Simulate – Simulation Properties на вкладке Range) установить время начала моделирования Start 0 сек и величину шага Step Size 0.001 сек, а также для начала время конца моделирования End 100 сек. (рис 2.15) .



Рис. 2.15. Задание свойств моделирования
По мере увеличения частоты время конца моделирования End придется уменьшать.

Подобрать значение коэффициента усиления kус вспомогательного усилителя (двойной щелчок) такое, чтобы при запуске моделирования амплитуды входного и выходного сигналов были примерно одинаковыми, например, взять для начала kус = 0.2.

Измерить на осциллограмме и занести в таблицу на рабочем поле Vissim’а и в документе Word’а значения амплитуды выходного сигнала, запаздывания выходного относительно входного, а также для контроля, величину периода синусоиды. Запаздывание нужно измерять в правой половине экрана, когда переходный процесс закончился.
Примечание.
Виртуальный лабораторный стенд позволяет проводить измерения с чрезвычайно высокой точностью, не достижимой на практике. При проведении реальных измерений обычно достаточно точности в 1 – 3 %. Именно с такой точностью (2 - 4 значащих цифры) и следует прочитывать результаты и заносить их в таблицы, а проводить вычисления с этими данными следует, удерживая на одну- две значащие цифры больше. Vissim позволяет построить и более точную модель реального лабораторного стенда, результаты измерений в которой будут отягощены ошибками. Для этого может быть использован генератор случайных сигналов (Blocks – Random Generator - gaussian). Для повышения точности отсчетов можно развернуть окно осциллографа на весь экран. Кроме того, можно увеличить фрагмент экрана, проводя по диагонали фрагмента курсором, удерживая левую кнопку и клавишу Ctrl. Для восстановления исходного вида осциллограммы, достаточно удерживая клавишу Ctrl щелкнуть правой кнопкой по экрану осциллографа (рис 2.16). Кроме того, можно щелкнуть дважды по центру графика, и в появившемся окне щелкнуть по кнопке Read Coordinates (Чтение координат). Появится перекрестие, которое можно поместить на точку, координаты которой следует прочитать, и щелкнуть левой кнопкой. Координаты будут отображены в специальном поле. Повторный щелчок по графику убирает перекрестие.



Рис. 2.16. Увеличение фрагмента осциллограммы
По мере увеличения частоты синусоиды генератора необходимо уменьшать и время моделирования, с тем, чтобы на осциллографе отображалось 3 – 5 периодов. Это упростит измерение запаздывания. Кроме того, следует подбирать и усиление kус вспомогательного усилителя с тем, чтобы амплитуды входного и выходного сигналов были примерно одинаковыми (например, отличались бы не более, чем в два раза).

Вычислить значения АЧХ, ЛАЧХ и ЛФЧХ. Равны ли частоты сигналов, отображаемых осциллографом, вычисленные в таблице 1, частотам задаваемым в генераторе?
Таблица 1 - ЛАЧХ и ЛФЧХ апериодического звена k = 0.2 , Т = 0.25 сек



Выполнив следующий пункт задания, нужно будет проставить в полученных там графиках точки, соответствующие значениям, вычисленным в таблице 1.
3. Определить влияние коэффициента усиления апериодического звена на его частотные характеристики. На лабораторном стенде задать значения параметров апериодического звена k = 0.2, Т = 0.25 сек, выделить блок и вызвать ЛАЧХ и ЛФЧХ (Analyze – Frequency Response). Оформить графики.

Задать значения параметров апериодического звена k = 1.0, Т = 0.25 сек,

k = 5.0, Т = 0.25 сек и построить частотные характеристики (рис.2.17).



Рис.2.17. Пример оформления частотных характеристик апериодического звена для k = 0.2, 1.0 и 10.0.
Как видно на рис. 2.17, частота сопряжения линий с наклоном 0 и – 20 дБ/дек, аппроксимирующих ЛАЧХ, равна 1/Т, где Т – постоянная времени апериодического звена, усиление на нижних частотах звена равно 20 lg(k). Т.о. чем больше коэффициент усиления звена, тем выше проходит его ЛАЧХ на нижних частотах. Наклон ЛАЧХ апериодического звена на высоких частотах составляет -20 дБ/дек. Аргумент ККП апериодического звена на частоте 1/Т равен – 450 и с увеличением частоты стремится к -900.

Пример помещения трех частотных характеристик на одном графике представлен на рис.2.18. Это упрощает анализ.



Рис.2.18. Пример помещения трех частотных характеристик на одном графике.
В работе следует сделать построение для k = 0.2, 1.0 и 5.0 .

Как видно, аргумент ККП (т.е. ЛФЧХ) апериодического звена не зависит от его коэффициента усиления.

Взять из таблицы 1 предыдущего пункта значения и проставить их в Paint’е на частотных характеристиках. Сделать выводы о соответствии характеристик, получаемых в Vissim’е экспериментально и вычисляемых.

Вычислить значения частотных характеристик в нескольких точках по формулам на калькуляторе и отобразить их на частотных характеристиках, полученных в Vissim’е. Сделать вывод о соответствии результатов, получаемых в Vissim’е.

Сохранить рисунки частотных характеристик, полученных в Vissim’е в личной папке.
4. Определить влияние постоянной времени апериодического звена на его частотные характеристики. Модифицировать лабораторный стенд (см. рис. 2.19): коэффициент усиления у всех трех апериодических звеньев сделать равным k = 10, а постоянные времени установить для первого 0.25 сек, у второго 1.0 сек и у третьего 10.0 сек.



Рис. 2.19. Модифицированный стенд для изучения ЧХ апериодического звена.

Осциллограммы не совпадают потому, что переходный процесс звеньев длится разное время, и фазовые запаздывания на заданной частоте 0.1 рад/сек у них разные, поскольку их постоянные времени разные.

Поскольку постоянные времени звеньев существенно, почти в 10 раз отличаются, то для более полного представления характеристик на одном графике целесообразно увеличить диапазон частот, в котором будут построены характеристики. Для этого выбрать в меню Analyze (Анализировать) --> Frequency Range (Частотный диапазон) и в окне диалога задать начальное значение Start равным 0.01, а конечное End оставить равным 100. Это позволит отобразить характеристики на четырех декадах изменения частоты.

Построить частотные характеристики для звеньев с постоянными времени Т = 0.25, 1.0 и 10.0 сек, и поместить их на одном рисунке (см. рис.2.20)



Рис.2.20. ЛАЧХ и ЛФЧХ апериодического звена при k = 10 и Т = 0.25, 1.0, 2.0 сек.
Проанализировать результаты, ответив на вопросы:

Как ведут себя ЛАЧХ и ЛФЧХ апериодического звена с изменением постоянной времени?

Как проходят линии аппроксимации ЛАЧХ на низких и не высоких частотах?

Что значит: наклон амплитудно- частотной характеристики – 20 дБ/дек?

Как связана частота точки сопряжения линий аппроксимации ЛАЧХ и постоянная времени апериодического звена?

К каким значениям стремится ЛФЧХ на низких и на высоких частотах?

Как связана частота, на которой ЛФЧХ апериодического звена равна -450 и его постоянная времени?

Вычислить значения частотных характеристик для нескольких точек по формулам на калькуляторе и отобразить их на частотных характеристиках, полученных в Vissim’е. Сделать вывод о соответствии результатов, получаемых в Vissim’е и по формулам.
5. Построить АЧХ и ФЧХ в Vissim’е в натуральном масштабе. В настройках свойств графиков частотных характеристик можно убрать флажки, задающие логарифмический масштаб, и обоснованно ожидать при этом, что получатся характеристики в натуральном масштабе, т.е. АЧХ и ФЧХ. Однако графики отображаются по оси частот не верно. (Vissim действительно не правильно переводит логарифмический масштаб в натуральный). Для правильного построения частотных характеристик в натуральном масштабе нужно использовать технику сохранения характеристики в файле и воспроизведения ее из файла.
2.3. Сохранение осциллограмм Vissim'а в файле и воспроизведение их из файла

В некоторых случаях необходимо сохранить осциллограммы Vissim'а и частотные характеристики, воспроизводимые осциллографом, в виде таблицы чисел, сохраняемой в специальном файле и при необходимости воспроизводить данные из этой таблицы на графике. Сохранение в файле тем более важно, что Vissim не сохраняет частотные характеристики в модели, и каждый раз при новом запуске стендов характеристики приходится строить заново.

1. Сохранить координаты кривой графика Vissim'а в файле. Открыть диаграмму Vissim, например лабораторный стенд для исследования колебательного звена, и построить его частотную характеристику. Щелкнуть дважды по центру окна графика, например, ЛАЧХ (логарифмической частотной характеристики). Появится окно диалога для Plot Properties установки свойств графика (рис. 2.21)



Рис. 2.21. Кнопка Save Data to File (Сохранить Данные в файле) на вкладке Options (Параметры) окна Plot Properties свойств осциллографа (plot'а)
Щелкнуть по кнопке Save Data to File. Откроется окно диалога сохранения файла. Обычно сразу открывается та папка, в которой последний раз была сохранена диаграмма Vissim'а. Если это не та папка, в которой находится открытая в Vissim'е модель, то целесообразно, чтобы не искать файл с данными, указать путь к папке, в которой сохранена текущая модель. Дать содержательное название файлу, например, в данном случае, LACH_Kol_Zv_d_01 (рис. 2.22).



Рис. 2.22. Сохранение файла в выбранной папке Save_As_File в формате ASCII, т.е. в виде таблицы чисел
Щелкнуть по кнопке Открыть. В папке, в данном случае в папке с названием Save_As_File появится файл LACH_Kol_Zv_d_01.dat. Убедитесь, что в вашей папке тоже появился файл данных. Этот файл может быть открыт Блокнотом. (рис.2.23). Вверху текстовые сведения о расположении файла модели, из которой сохранены данные в файл и время его создания, а ниже, через две запятые, в два столбца, идут значения, в данном случае, частоты (левый столбец) и усиления в натуральных единицах (кратах, "разах"). Отметим, что значения усиления сохраняются в файле в натуральных единицах независимо от того, в каком масштабе был представлен исходный график: в натуральном или логарифмическом.


Рис. 2.23. Файл данных может быть просмотрен с помощью Блокнота.
2. Подготовка данных файла .dat к импорту. Двойные запятые, разделяющие столбцы со значениями частоты и усиления в файле .dat, препятствуют импорту данных в Vissim'е. Поэтому их нужно подготовить, заменив две запятых на пробел. Выполняется это в Word. Запустить Word. Открыть из него файл LACH_Kol_Zv_d_01.dat. Выделить две запятых в верхней строке данных. Выбрать: Правка – Заменить (рис. 2.24)



Рис. 2.24. Замена запятых в файле .dat на пробел с помощью программы Word
Щелкнуть по кнопке Заменить все. Появится окно с сообщением о проведенных заменах. Утвердить замену щелчком по кнопке ОК, закрыть окно замены и сохранить файл в Ворде с расширением .dat, согласившись с сохранением в формате "Обычный текст". В результате запись данных в файле LACH_Kol_Zv_d_01.dat примет вид (Блокнот) (рис.2.25). Первый, левый столбец - частота, второй - усиление в натуральных единицах.



Рис. 2.25. Данные в файле LACH_Kol_Zv_d_01.dat разделены пробелами.
2. Импорт данных из файла в диаграмму Vissim'а. Открыть новую диаграмму Vissim'а. Вынести на рабочее поле блок импорта из файла (Blocks - Signal Producer - import), осциллограф (Blocks - Signal Consumer - plot) и присоединить верхний выход блока import, соответствующий первому столбцу данных, т.е. в данном случае значениям частот, к верхнему входу осциллографа. Второй выход блока, соответствующий второму столбцу данных со значениями усиления, присоединить ко второму входу осциллографа (рис.2.26). Данные будут индицироваться на осциллографе.



Рис. 2.26. Помещение на рабочее поле блока import.
Поскольку в файле данных только два столбца, можно удалить третий выход блока import. Щелкнуть по кнопке на панели инструментов Vissim'а со стрелкой вправо и знаком минус Remove Connector (удалить контакт), переместить курсор к нижнему, третьему выходу блока и при появлении маленького прямоугольника с линией внутри, щелкнуть левой кнопкой:



Рис. 2.27. Удаление третьего выхода блока import
Указать файл, из которого следует импортировать данные: дважды щелкнуть по блоку import, и в окне диалога выбрать нужный файл LACH_Kol_Zv_d_01.dat, щелкнув по кнопке Select File и указав путь к нему, щелкнуть по кнопке Открыть (рис 2.28). Значение Start Column (Начальный столбец) выбрано по умолчанию равным 1, что означает, что значения из первого столбца файла данных будут подаваться на первый, верхний выход блока import. Щелкнуть ОК в окне Import Properties.



Рис. 2.28. Выбор файла для импорта данных в модель.
Развернуть на 1800 для экономии места осциллограф (Выделить блок - Меню Edit - Flip Horizontal) и поместить его под блоком импорт, в котором уже появился путь к выбранному файлу данных с координатами АЧХ (рис. 2.29). Файл, из которого импортируются данные, находится не в той папке, в которой сохранена эта модель, поэтому Vissim указывает в этом блоке import полный путь к файлу.



Рис.2.29. Диаграмма Vissim для вывода на осциллограф АЧХ.
4. Настроить параметры блоков и моделирования. Щелкнуть дважды по центру осциллографа и в окне диалога на вкладке Options (Параметры) установить флажки XY Plot (XY график), а также Grid Lines (Линии сетки) (рис.2.30). Щелкнуть ОК.



Рис. 2.30. Задание параметров осциллографа на вкладке Options.
Параметр XY Plot (XY график) означает, по горизонтальной оси будет откладываться не время, а значения, поступающие на один из входов осциллографа, например, в данном случае, это данные, которые будут поступать на верхний вход осциллографа и дадут координаты точек по оси Х (параметр X axis принят равным 1 - см. рис. 2.30), а значение, поступающие на второй вход, в данном случае значение усиления, дадут координаты точек по оси Y. Как видно на рис. 2.28, установлен флажок Interpolate (Интерполировать), поэтому будет построена непрерывная кривая.

Задать параметры моделирования: меню Vissim'а Simulate (Моделировать) - Simulation Properties (Свойства моделирования): Start = 0, End = 5, Step Size = 0.001.
1   2   3   4

Похожие:

Лабораторная работа №3 частотный анализ типовых звеньев iconЛекция №4. Характеристики типовых звеньев сар (Слайд 1)
Под типовым звеном понимается такое звено, которое описывается дифференциальным уравнением не выше второго порядка. На рис. 1 представлена...
Лабораторная работа №3 частотный анализ типовых звеньев iconКурс, семестр, 20 часов
Частотный отклик. Импульсный отклик свободного пространства. Линза как фазовый транспарант. Расчет импульсного отклика простейшей...
Лабораторная работа №3 частотный анализ типовых звеньев iconЛабораторная работа №1 Работа в Oracle Database Express Edition 1 Лабораторная работа №6
Лабораторная работа Выполнение расчетов с использованием программирования в среде Visual Basic for Applications
Лабораторная работа №3 частотный анализ типовых звеньев iconЛабораторная работа 8 Спектральный анализ и синтез
Гармонический анализ и синтез ~ Классический спектральный анализ ~ Численный спектральный анализ ~ Спектральный анализ на основе...
Лабораторная работа №3 частотный анализ типовых звеньев iconЛабораторная работа №5 Анализ операций с ценными бумагами
Лабораторная работа №5 включает 5 заданий. Для выполнения этих заданий необходимо ознакомиться с теоретическим материалом, приведенным...
Лабораторная работа №3 частотный анализ типовых звеньев iconЛабораторная работа №5 микроструктура цветных сплавов
Цель работы: изучить классификацию, микроструктуру, свойства и назаначение типовых цветных сплавов машиностроения
Лабораторная работа №3 частотный анализ типовых звеньев iconЛабораторная работа №3. Знакомство с прерываниями. Лабораторная работа №4. Программная обработка клавиатуры
Лабораторная работа №1. Знакомство с общим устройством и функционированием ЭВМ. Изучение структуры процессора, организации памяти,...
Лабораторная работа №3 частотный анализ типовых звеньев iconВопросы к экзамену по дисциплине «Теория Автоматического Управления»
Временные характеристики: общие понятия. Переходные и весовые функции типовых динамических звеньев: усилитель, апериодического первого...
Лабораторная работа №3 частотный анализ типовых звеньев iconМетодические указания к лабораторным работам по дисциплине «Теория автоматического управления» для специальности 140604. 65
Цель работы: изучение влияния параметров инерционных типовых линейных звеньев на вид их частотных характеристик (ЧХ)
Лабораторная работа №3 частотный анализ типовых звеньев iconЛабораторная работа по теме: «ms doc. Основные команды.»
Мбоу «сош №8 г. Петровска Саратовской области» Лабораторная работа в среде ms dos
Разместите кнопку на своём сайте:
ru.convdocs.org


База данных защищена авторским правом ©ru.convdocs.org 2016
обратиться к администрации
ru.convdocs.org