Лабораторная работа №1 3 Создание ситуационного плана миигаиК 3 Лабораторная работа №2 8 Оцифровка части карты и создание базы данных 8



Скачать 469.91 Kb.
страница6/11
Дата06.07.2013
Размер469.91 Kb.
ТипЛабораторная работа
1   2   3   4   5   6   7   8   9   10   11

Лабораторная работа № 7

Помещение карт в OLE-программы


Цель работы: научиться помещать специальные OLE-объекты из одной программы в другую.
В этой работе мы научимся помещать карты из MapInfo в другие программы, поддерживающие OLE – протокол. В частности в MS Word и Excel.
OLE (англ. Object Linking and Embedding, произносится как oh-lay [олэй]) — технология связывания и внедрения объектов в другие документы и объекты, разработанные корпорацией Майкрософт.
OLE позволяет передавать часть работы от одной программы редактирования к другой и возвращать результаты назад. Основное преимущество использования OLE (кроме уменьшения размера файла) в том, что она позволяет создать главный файл, картотеку функций, к которой обращается программа. Этот файл может оперировать данными из исходной программы, которые после обработки возвращаются в исходный документ. Вторая версия этого протокола называется ActiveX, которая активно используется в Интернет-браузерах для просмотра мультимедиа.
Способность MapInfo использовать OLE-внедрения превратит Ваше приложение, такое как текстовый процессор или электронная таблица, в "мини-MapInfo". Вы сможете создавать, просматривать, редактировать и печатать карты для подготовки презентаций или печатных отчетов. Это становится возможным при помощи механизма OLE-внедрения объектов. Приложение-сервер (здесь MapInfo Professional) поставляет информацию, которая принимается в приложении-клиенте. Использование функций внедрения MapInfo Professional позволяет вам поместить окно карты в любое приложение, поддерживающее объекты OLE, и работать с этим окном непосредственно из приложения.
Поскольку объекты MapInfo Map представляют собой действующие OLE-объекты, то, на самом деле, вы в фоновом режиме запускаете MapInfo Professional. Когда активна карта приложения-контейнера, меню этого приложения изменится и будет представлять собой меню доступных этому приложению команд и функций MapInfo Professional. Подмножество команд и функций получило название MapInfo Map (Некоторые приложения OLE-контейнеры создают отдельное окно для редактируемого объекта). По щелчку мыши или по команде меню вы получите доступ к функциональности MapInfo Professional непосредственно в приложении, в котором вы работаете.
Откройте в MapInfo файл RUS_OBL.tab, создайте в своей папке с работами пустые документы Word и Excel, откройте их.

Есть несколько способов помещения карт из MapInfo в другие программы. В нашем примере это Word и Excel.


Щелкните на пустом месте на карте в MapInfo, чтобы ни один объект не был выбран, зайдите в меню «Правка – Копировать карту» (если выбран объект на карте, пункт будет недоступен), перейдите в документ Excel, нажмите Ctrl+V или правой кнопкой мыши – вставить.

Вставится карта.




Теперь дважды щелкните на ней левой кнопкой мыши. Верхнее меню изменилось, теперь вы работаете не с Excel, а с MapInfo, хотя и урезанным вариантом.

Здесь можно открыть другую таблицу, управлять слоями, создать тематическую карту, получить информацию об объектах. Щелкните на место вне карты и перед нами снова интерфейс Excel.

Теперь попробуем тоже самое сделать в Word. Перейдите в документ Word и вставьте таким же образом карту из буфера обмена – она почему-то вставится как картинка, а не как OLE-объект. Если попробовать другой способ вставки через меню «Правка – Специальная вставка – MapInfo Map (объект)», то выдаст ошибку:
В таких случаях есть способ, который вставит карту из MapInfo как OLE-объект.

В программе есть инструмент «Дубль окна»

Сначала сверните окна MapInfo и Word, чтобы они были видны рядом одновременно, потом нажмите на инструмент «Дубль окна», левой кнопкой мыши перетащите окно карты в окно документа Word, дважды щелкните по возникшей карте – теперь ее можно редактировать, т.е. выполнять те немногочисленные действия, что и в предыдущий раз в Excel.
Есть еще способ вставки OLE-объектов в документы Word и Excel.

Находясь в документе упомянутых программ, зайдите в меню «Вставка – объект», вам покажет список программ, установленных на компьютере, из которых возможно принять OLE-объект:

Выберите в нем MapInfo 9.0.0 Map объект и нажмите «ок».
Появится контейнер с пустым пока объектом MapInfo, при двойном щелчке на который будет доступно его редактирование
Откройте в нем таблицу RUS_BORD.tab

Щелкните мышью за пределами объекта, чтобы сделать его неактивным.

Теперь щелкните правой кнопкой мыши по объекту и выберите в контекстном меню «Объект MapInfo Map – Преобразовать». В этом меню можно преобразовать большое окно карты в значок, при двойном щелчке на который откроется всё та же карта. Для обратного преобразования можно проделать ту же операцию, только снять галочку «В виде значка» и изменить размеры карты на бОльшие.
Это может быть удобно в некоторых случаях, чтобы сэкономить место на странице.

Объекты из OLE-программ перетаскиваются мышью в другие программы-клиенты с помощью особых инструментов, которые находятся в программе-сервере (например, MapInfo и инструмент «Дублировать окно»), либо просто через буфер обмена (копировать-вставить), либо мышью, зажав клавишу Ctrl (появится знак + под курсором).

Такой подход называется Drag-and-Drop и используется почти во всех современных windows-приложениях.
На этом работа закончена. В итоге у вас должно быть два документа – один Excel с картой России, один Word с картинкой карты, вставленной картой через «Дубль окна» и со значком карты, вставленной из меню Word «Вставка». Перед сдачей работы вспомните, что такое OLE, OLE-объекты, где используются. Подумайте, что вы увидите, если вставив OLE-объект на этом компьютере в документ Word, принесете его домой, где не установлена программа MapInfo?
1   2   3   4   5   6   7   8   9   10   11

Похожие:

Лабораторная работа №1 3 Создание ситуационного плана миигаиК 3 Лабораторная работа №2 8 Оцифровка части карты и создание базы данных 8 iconЛабораторная работа №12 Создание таблиц в ms access. Теоретические сведения. 1 Создание базы данных
Для создания новой базы данных нужно при открытии ms access выбрать опцию Новая база данных. В появившемся диалоговом окне указать...
Лабораторная работа №1 3 Создание ситуационного плана миигаиК 3 Лабораторная работа №2 8 Оцифровка части карты и создание базы данных 8 iconЛабораторная работа №13 Создание реляционной базы данных, заполнение бд, создание форм
Программа ms access позволяет создавать реляционные бд, а также обеспечивать их обработку с помощью запросов, форм и отчетов
Лабораторная работа №1 3 Создание ситуационного плана миигаиК 3 Лабораторная работа №2 8 Оцифровка части карты и создание базы данных 8 iconЛабораторная работа 23 Создание таблиц баз данных ms access. Создание межтабличных связей
Цель работы: Научиться создавать таблицы базы данных, задавать их структуру, выбирать типы полей и управлять их свойствами. Освоить...
Лабораторная работа №1 3 Создание ситуационного плана миигаиК 3 Лабораторная работа №2 8 Оцифровка части карты и создание базы данных 8 iconЛабораторная работа №25 по дисциплине "Информатика" т ема : субд access. Создание многотабличной базы данных. Задание
Группа – содержит информацию о студентах
Лабораторная работа №1 3 Создание ситуационного плана миигаиК 3 Лабораторная работа №2 8 Оцифровка части карты и создание базы данных 8 iconMicrosoft Access 2003 Работа №1 Основные понятия реляционных баз данных Создание таблиц в Microsoft Access
Создание учебной базы данных. Знакомство с основными приемами работы конструктора базы данных. Ввод данных в табличном режиме
Лабораторная работа №1 3 Создание ситуационного плана миигаиК 3 Лабораторная работа №2 8 Оцифровка части карты и создание базы данных 8 iconЛабораторная работа №1 Работа в Oracle Database Express Edition 1 Лабораторная работа №6
Лабораторная работа Выполнение расчетов с использованием программирования в среде Visual Basic for Applications
Лабораторная работа №1 3 Создание ситуационного плана миигаиК 3 Лабораторная работа №2 8 Оцифровка части карты и создание базы данных 8 iconПрактикум по курсу Информатика (раздел Работа с пакетами прикладных программ) для студентов заочной формы обучения
Лабораторная работа №6. Обобщение данных. Создание таблицы подстановки. Подведение итогов 28
Лабораторная работа №1 3 Создание ситуационного плана миигаиК 3 Лабораторная работа №2 8 Оцифровка части карты и создание базы данных 8 iconЛабораторная работа №1 Тема: Создание и заполнение таблиц, создание связей между таблицами в Microsoft Access 2010
Примечание: для группы c-22 обязательны первые 6 лабораторных работ, 7-ая по желанью
Лабораторная работа №1 3 Создание ситуационного плана миигаиК 3 Лабораторная работа №2 8 Оцифровка части карты и создание базы данных 8 iconЛабораторная работа №2 Триггеры в распределённой базе данных
Для созданной в лабораторной работе №1 базы данных с оптимальным размещением таблиц по двум узлам создать набор триггеров для поддержания...
Лабораторная работа №1 3 Создание ситуационного плана миигаиК 3 Лабораторная работа №2 8 Оцифровка части карты и создание базы данных 8 iconЛабораторная работа № Создание тематической карты
Цель работы: научится анализировать данные, присваивать графическим объектам на карте цветов, штриховок, типов линий и символов на...
Разместите кнопку на своём сайте:
ru.convdocs.org


База данных защищена авторским правом ©ru.convdocs.org 2016
обратиться к администрации
ru.convdocs.org