Отчет по учебной практике предметной по дисциплине «Информационные системы»



Скачать 152.28 Kb.
Дата25.07.2014
Размер152.28 Kb.
ТипОтчет


министерство образования и науки российской федерации.

федеральное агентство по образованию.

государственное образовательное учреждение

высшего профессионального образования.

«дагестанский государственный

технический университет».

кафедра информационных систем в экономике.


Отчет

по учебной практике (предметной по дисциплине «Информационные системы»)

Выполнил:

студент группы И-412, 2 курса,

ФИС, Бекеров М. Б.

Руководитель: ст. преподаватель Селимов А.Н.


Махачкала 2006 г.
введение.
Цель практики:

  • углубленное изучение структуры и организации функционирования информационных систем и сетей;

  • углубленное изучение программных средств реализации документальных и фактографических ИС.



Постановка задачи:

  1. Разработка базы данных (таблицы) для хранения и обработки информации согласно варианту индивидуального задания.

  2. Разработка программы по обработке данных и формированию выходных документов.

Программа в СУБД visual FoxPro 7.0 должна осуществлять следующие функции

    • ввод данных в файл базы данных;

    • корректировку данных в файле (таблице);

    • распечатку записей из таблицы (файла БД);

    • печать документов заданных форм;

    • выход из среды СУБД Visual FoxPro 7.0.


Краткие теоретические сведения

Главное окно Visual FoxPro



Заголовок находится в верхней части главного окна и содержит три объекта: копию значка программы Visual FoxPro, заголовок главного окна и значки управления этим окном.Строка меню содержит иерархическое меню Visual FoxPro. Список пунктов меню зависит от типа активного окна.Visual FoxPro предоставляет в распоряжение пользователя много самых разнообразных панелей инструментов для работы с базами данных, формами, отчетами и запросами. Эти панели инструментов содержат набор кнопок, причем этот набор зависит от назначения конкретной панели инструментов. При первом запуске Visual FoxPro после его установки на экране отображается стандартная панель инструментов.В нижней части главного окна расположена строка состояния, в которую выводится информация о текущем состоянии активного окна, краткое описание выбранной кнопки панели инструментов или пункта меню. Вид информации, отображаемой в строке состояния, зависит от типа активного окна. Например, в окне конструктора форм в строке состояния выводится наименование активного объекта формы, а при просмотре таблицы в режиме Browse в левой части строки состояния отображается наименование открытой таблицы, в середине строки состояния — номер текущей записи и индикатор режима работы.

В процессе работы в главном окне Visual FoxPro открываются окна конструкторов форм, отчетов, запросов, проекта и другие окна. Все эти окна являются дочерними по отношению к главному окну и закрываются при его закрытии.



Системное меню

Заголовок главного окна содержит уменьшенную копию значка программы, текст "Microsoft Visual FoxPro" и кнопки управления размерами главного окна. При щелчке на значке пиктограммы открывается системное меню, содержащее команды перемещения и изменения размеров главного окна. В табл. приведены команды, доступные из системного меню.



Таблица Команды системного меню

Команда

Назначение

Восстановить

Восстанавливает предыдущий размер или максимизации окна после минимизации

Переместить

Активизирует главное окно Visual FoxPro и позволяет перемещать его с помощью клавиш перемещения курсора

Размер

Активизирует главное окно Visual FoxPro и позволяет изменять его размеры с помощью клавиш перемещения курсора

Свернуть

Уменьшает окно Visual FoxPro до размеров значка

Развернуть

Максимизирует размер главного окна Visual FoxPro. Максимизированное окно не имеет рамки

Закрыть

Закрывает главное окно программы Visual FoxPro

Краткий обзор меню Visual FoxPro

При отсутствии в главном окне Visual FoxPro других открытых окон строка меню содержит пункты File (Файл), Edit (Правка), View (Вид), Tools (Инструменты), Program (Программа), Windows (Окна) и Help (Справка). При открытии окон в меню добавляются команды, применимые только к объектам данного окна. Например, при работе с таблицами в главное меню добавляется пункт меню Table (Таблица), при открытии на экране формы в меню появляется пункт Form (Форма).

  Меню File (Файл) содержит команды, связанные с доступом к файлам. Эти команды позволяют создавать новые файлы разных типов(New), открывать существующие файлы(Open), закрывать(Close), сохранять(Save,Save as) и печатать(Print) их.Команда Save As HTML (Сохранить файл в формате HTML), появившаяся в Visual FoxPro 6.0, открывает диалоговое окно Save As HTML, позволяющее сохранить текущую форму, меню, отчет или таблицу в формате HTML (Hypertext Markup Language).Очень удобна команда Revert (Возвратить), позволяющая отменить все изменения файла, сделанные в текущем сеансе редактирования.

Меню Edit (Правка) имеется во многих приложениях Windows. В Visual FoxPro команды этого меню используются при создании форм и отчетов, редактировании программ.Команды Paste Special (Специальная вставка), Insert Object (Вставить объект), Object (Объект) и Links (Связи) применимы только к полям типа General и OLE-объектам. Остальные команды применяются при редактировании как программ, так и полей таблиц.

Незнакомой для вас по другим приложениям Windows может оказаться команда Go to Line (Переход на строку), предназначенная в Visual FoxPro для работы с программами. С помощью данной команды можно переходить в тексте программы к строке с указанным номером.

Последняя в меню — команда Properties (Свойства), при выборе которой открывается диалоговое окно Edit Properties (Редактирование свойств), позволяющее задавать параметры сохранения программных файлов, просматривать их свойства, дату последнего редактирования и занимаемый объем на диске.Этот пункт меню содержит команды, управляющие просмотром текущего открытого файла. Если вы не просматриваете файл, то меню содержит всего одну команду Toolbars (Панели инструментов). Эта команда открывает диалоговое окно, в котором перечислены панели инструментов, используемые при работе в Visual FoxPro.Команда Properties (Свойства) появляется в данном меню тогда, когда вы находитесь в конструкторе форм и конструкторе классов. При выборе этой команды открывается диалоговое окно Properties, позволяющее просмотреть и изменить свойства объектов, расположенных в форме.

При просмотре таблиц или редактировании форм, меню или отчетов в меню появляются дополнительные команды. Например, если вы работаете с таблицами, в меню появляется несколько новых команд. Команды Edit (Редактирование) и Browse (Обзор) переводят таблицу в режим просмотра и редактирования содержащихся в ней записей. Отличие между этими двумя командами состоит в стиле отображения содержимого таблицы.

Меню Format (Формат) содержит команды, управляющие характеристиками шрифта, выравниванием текста и объектов, определением интервалов между объектами. Однако при работе с различными конструкторами становятся доступными и дополнительные команды.Это меню содержит мастеров и средства отладки программ.Первой в меню располагается команда Wizards (Мастера), открывающая список мастеров Visual FoxPro. Мастер — это программа, которая помогает пользователю в решении таких задач, как создание форм, отчетов, таблиц. Процесс создания при этом заключается в ответах на вопросы мастера относительно создаваемого объекта.Далее в меню расположена команда Spelling (Орфография). Ее можно использовать для проверки правильности написания любого текста.Команда Debugger (Отладчик) предназначена для отладки. Она открывает диалоговое окно Visual FoxPro Debugger, в котором вы можете просмотреть значения переменных, элементов массива, полей, значения, возвращаемые функциями Visual FoxPro, и т. д.

В Visual FoxPro 6.0 в меню Tools (Инструменты) появились новые команды Component Gallery (Галерея компонентов), Coverage Profiler (Анализ выполнения) и Run Active Document (Запуск активного документа). Команда Component Gallery открывает окно Catalogs — Component Gallery для работы в Галерее компонентов Visual FoxPro. Команда Coverage Profiler позволяет просмотреть информацию о выполненной программе. Run Active Document открывает диалоговое окно Run Active Document для выбора активного документа и его запуска. Последняя команда в меню Tools — Options (Параметры). С ее помощью можно настраивать конфигурацию Visual FoxPro.

Меню Program (Программа) содержит команды, связанные с выполнением и компиляцией программ.

В меню Windows (Окна) имеются команды, которые управляют открытыми на экране окнами. С помощью этих команд можно упорядочивать, скрывать, очищать окна и переходить из одного окна в другое. Кроме того, команды данного меню позволяют активизировать любое открытое окно.Команда Command Window (Командное окно) из меню Windows активизирует окно Command (Команда), позволяющее использовать команды при работе с Visual FoxPro.

Для открытия окна Data Session, которое содержит список всех открытых в данном сеансе таблиц и отношений между ними, используется команда Data Session (Окно данных).В центре окна Data Session находятся кнопки управления таблицами. Кнопка Properties открывает окно, позволяющее просмотреть и изменить текущие свойства таблицы. Для открытия таблицы в новой рабочей области используется кнопка Open. Кнопка Browse (Табличный режим) открывает таблицу для просмотра содержащихся в ней записей. Кнопка Close (Закрыть) окна Data Session закрывает таблицу в текущей рабочей области, а кнопка Relations (Отношения) позволяет определить отношения между открытыми таблицами.



Help (Справка) — последняя команда меню главного окна.

Назначения быстрых кнопок:






Кнопка

Название

Назначение



New (Новый)

Создает новый файл



Open (Открыть)

Открывает существующий файл



Save (Сохранить)

Сохраняет открытый файл



Print One Copy (Печатать одну копию)

Печатает содержимое активного окна



Print Preview (Просмотр печати)

Открывает окно предварительного просмотра печатаемого документа



Spelling (Орфография)

Проверяет орфографию



Cut (Вырезать)

Удаляет выделенный текст или выделенные объекты и помещает их в буфер



Copy (Копировать)

Копирует в буфер выделенный текст или выделенные объекты, не удаляя их



Paste (Вставить)

Вставляет содержимое буфера. Действие этой кнопки зависит от того, в каком из режимов вы работаете



Undo (Отменить)

Отменяет последнее выполненное действие



Redo (Восстановить)

Восстанавливает отмененные действия



Run (Выполнить)

Запускает на выполнение



Modify Form (Модифицировать форму)

Позволяет модифицировать форму



Database (База данных)

Содержит список открытых баз данных



Command Window (Командное окно)

Открывает командное окно



Data Session Window (Окно сеанса данных)

Открывает окно Data Session



Form (Форма)

Вызывает мастер форм



Report (Отчет)

Вызывает мастер отчетов



AutoForm Wizard (Мастер автоформы)

Создает стандартную форму для текущей таблицы



AutoReport Wizard (Мастер автоотчета)

Создает стандартный отчет для текущей таблицы



Help (Справка)

Вызывает справочную систему


Типы полей

Поля таблицы предназначены для хранения данных: чисел, текстов, дат, графики и т. д. Для определения типа данных, размещаемых в поле, используются тип поля, его ширина и количество знаков после запятой. Для их ввода предназначены столбцы Type (Тип), Width (Ширина) и Decimal (Десятичные) вкладки Fields (Поля) конструктора таблиц.

В Visual FoxPro допустимыми являются типы полей, указанные в табл.

Таблица . Типы полей Visual FoxPro


Тип

Наименование

Отображаемые данные

Текстовый

Character, Character (binary)

Текстовые поля могут содержать буквы, цифры и специальные символы. Максимальная ширина поля составляет 254 символа. Тип Character (binary) используется в том случае, если не требуется учитывать кодовую страницу отображаемых данных

Числовой

Integer, Numeric, Float, Double

Integer отображает целые числа от -2147483647 до +2147483647.

Числовые поля типа Numeric и Float отображают данные с фиксированной точкой в диапазоне от -0.9999999999*10+19 до +0.9999999999*10+20.



Тип данных Double используется для хранения данных с высокой точностью в диапазоне от +4.94065648541247*10-324 до +1.79769313486232*10+308

Денежный

Currency

В поле денежного типа могут содержаться числа от -922,337,203,685,477.5807 до 922,337,203,685,477.5807

Дата

Date

В поле типа Date может содержаться любая дата от 01.01.0001 до 31.12.9999 г.

Дата и время

DateTime

В поле типа DateTime может содержаться любая дата от 01.01.0001 до 31.12.9999 г. и время от 00:00:00 a.m. до 11:59:59 p.m.

Логический

Logical

Содержит логическое значение True(.Т.) (Истина) или False(.F.) (Ложь)

Текстовое поле произвольной длины

Memo, Memo(binary)

Memo-поле содержит символьные данные большого объема

Двоичное поле произвольной длины

General

Поле данного типа предназначено для хранения в таблицах изображений и других двоичных данных


Файлы, используемые в Visual FoxPro и их расширения


База данных в Visual FoxPro - это совокупность таблиц, отношений между таблицами, индексов, триггеров и хранимых процедур. Создание базы данных в Visual FoxPro осуществляется в интерактивном режиме с помощью конструктора базы данных, который позволяет.Расширение Database(*.dbc)

Таблицы составляют основу базы данных. В них хранится вся необходимая информация. В дальнейшем данные в таблице будут дополняться новыми данными, редактироваться или исключаться из таблицы. Вы сможете просматривать данные таблиц с помощью форм или упорядочивать их по заданному критерию. Информация, содержащаяся в таблицах, может быть использована для составления отчетов. Кроме того, используя диаграммы, вы можете графически представить информацию, содержащуюся в базе данных.Таблица состоит из строк и столбцов и имеет уникальное имя в базе данных. В каждой из таблиц содержится информация о каких-либо объектах одного типа.В Visual FoxPro 7.0 мы можем создавать как таблицы, входящие в базу данных, так и отдельные таблицы, называемые свободными, аналогичные создаваемым в предыдущих версиях FoxPro. В данной главе мы остановимся на создании таблиц, входящих в состав базы данных, поскольку в этом случае вы сможете использовать все средства, предоставляемые Visual FoxPro для работы с таблицами.

Формы используются для просмотра или ввода данных в таблицы. Данные можно вводить в таблицы и непосредственно, но, применяя формы, можно значительно ускорить этот процесс и сделать его более эффективным. Форма содержит некоторые или все поля таблиц, в которые вы вводите информацию. Чтобы создавать формы, вы можете использовать мастер форм или конструктор форм. Мастер форм предоставляет целый ряд шаблонов, которые определяют соотношение между помещаемыми в форму таблицами, вид отображения данных и порядок размещения полей. Конструктор форм предназначен для создания сложных форм.

Отчеты используются для печати информации, содержащейся в базе данных. Примерами отчетов являются прайс-лист товаров, список покупателей, оборотная складская ведомость. Как правило, отчеты создаются в том случае, если информацию необходимо передавать кому-либо в печатном виде. Для создания отчетов в Visual FoxPro, как и для форм, используются мастер и конструктор отчетов. С помощью мастера отчетов вы можете быстро создать собственный отчет на основе имеющихся шаблонов. Применяя конструктор отчетов, можно создавать отчеты произвольной сложности, включая многоуровневую группировку данных и размещение вычисляемых полей.

Запросы являются средством выборки данных из одной или нескольких таблиц. В Visual FoxPro для создания запроса вы можете использовать как конструктор запросов, так и специализированный язык Structured Query Language (SQL). Результаты выполнения запроса могут отображаться в форме, выводиться в виде отчетов и диаграмм или сохраняться в указанной вами таблице.

Программы, написанные на языке Visual FoxPro, являются объектно-ориентированными. С помощью них вы обрабатываете события в форме, создаете объекты, осуществляете различные вычисления, управляете базой данных. Для удобства работы вы можете объединить программы в библиотеки.

Основные команды, используемые для создания, изменения, дополнению базы данных.

  • Create <имя> - создание;

  • Browse открывает окно просмотра и выводить записи из текущей или указанной таблицы;

  • Modify structure открывает структуру для изменения или добавления параметров;

  • Edit выводить поля для редактирования;

  • Useоткрывает таблицу и связанные в ней индексы;

  • Append –добавление данных.

Вариант №3

Справочная система «Учет выплаты квартплаты».
Предполагаемые поля:

  • улица,

  • номер дома,

  • номер квартиры,

  • ФИО квартиросъемщика,

  • количество жильцов,

  • площадь,

  • дата последнего платежа,

  • наличие и тип льгот.

Осуществить: ввод нового платежа, фильтрацию по автору, по названиям, поиск нужного наименования, вывод общего списка БД в различных режимах, по возрастанию ФИО автора, по дате приоритета.

Для создания базы данных выполните следующие действия:

1. Откройте созданный проект.

2. Выберите в верхней части окна конструктора проектов вкладку Data(Данные). Курсор по умолчанию устанавливается в начале вкладки на значении Database (База данных).

3. Нажмите кнопку New в окне проекта.

4. В открывшемся диалоговом окне New Database (Новая база данных) нажмите кнопку New Database.




Выберите в верхней части окна конструктора проектов вкладку Data(Данные).

Нажмите кнопку New в окне проекта.

В открывшемся диалоговом окне нажмите кнопку New Table.



В появившемся окне введите поля БД.



Затем, нажав OK, набираем в окне command команду append и заполняем таблицу, вводя поочерёдно данные в предполагаемые поля.



Заполнив таблицу, набираем следующую команду browse и получаем таблицу следующего вида.



Затем, набрав команду display all, мы получим следующую таблицу.



А далее мы последовательно создаём форму.















Следующим нашим шагом будет создание запросов к нашей базе данных.









заключение.

Анализ полученных результатов показывает, что данная БД может быть использована в практике и может выдавать информацию по запросам пользователей и тем самим упростить работу по поиску, добавлению и удалению информации.



Список литературы.


  1. Мусина Т.В., Пушенко В.А. Visual FoxPro 7.0. Учебный курс-К.:ВЕК+, к.: BookStar, 2002.-400с.

  2. Симонович С. Информатика для юристов и экономистов- СПБ “Питер”.2003 г.

  3. Информатика: учебник.-3-е перераб. изд./Под ред. Проф. Н.В. Макаровой.-2002 г.

  4. Андреев А.Г. и др. Microsoft Windows 2000 Professional. Русская версия СПб.: БХВ-Петербург,2002.-752 с.

  5. Петров мю, Молочкова В.. Компьютерная графика: Учебник для ВУЗов(+CD)-СПб “Питер”,2003.

  6. Петров В.Н. Информационные системы.- СПб.: Издательский дом “Питер”, 2003 г.

  7. Сильвия Бемер FoxPro 2.6 для Windows: Пер. С нем. К.: Торгово-издательское бюро BHV , 1995,-464 с.



Похожие:

Отчет по учебной практике предметной по дисциплине «Информационные системы» iconУчебной программы дисциплины «Программирование OpenGl» для ооп «230400. 62 Информационные системы и технологии» по циклу Б3 профессиональный цикл
Пк-12: способность разрабатывать средства реализации информационных технологий (методические, информационные математические, алгоритмические,...
Отчет по учебной практике предметной по дисциплине «Информационные системы» iconРаспределенные системы обработки данных в корпоративных информационных системах по дисциплине: Информационные технологии управления
Технология клиент-сервер 23 Глава 3 Аппаратное и программное обеспечение распределенной обработки данных 33 1 Интегрированные информационные...
Отчет по учебной практике предметной по дисциплине «Информационные системы» iconРабочая программа для студентов направления 230400. 62 «Информационные системы и технологии»
...
Отчет по учебной практике предметной по дисциплине «Информационные системы» iconЭкзаменационные вопросы по информатике Направление подготовки «Адаптивная физическая культура»
Основные понятия информатики: информационная среда, информационные технологии, информационные системы, базы данных, интеллектуальные...
Отчет по учебной практике предметной по дисциплине «Информационные системы» icon1. Понятие об информационной системе
В зависимости от предметной области информационные системы могут очень силь­но различаться по своим функциям, архитектуре, реализации....
Отчет по учебной практике предметной по дисциплине «Информационные системы» iconОтчет по учебной вычислительной практике [Фамилия Имя Отчество, группа студента] Проверил
После того, как документ готов, здесь следует вставить
Отчет по учебной практике предметной по дисциплине «Информационные системы» iconКонтрольные вопросы по отдельным модулям и в целом по всей учебной дисциплине
Проектирование учебного процесса по учебной дисциплине (назначение и трудоемкость дисциплины) для опп
Отчет по учебной практике предметной по дисциплине «Информационные системы» iconУчебно-методический комплекс по дисциплине «Теория информации и кодирования»
Государственного образовательного стандарта высшего профессионального образования по специальности: 230101, вычислительные машины,...
Отчет по учебной практике предметной по дисциплине «Информационные системы» iconРабочая программа По дисциплине «Теория распознавания образов» По специальности 230201. 65 Информационные системы и технологии

Отчет по учебной практике предметной по дисциплине «Информационные системы» iconОтчет по учебной практике студента группы истбд-11 Быстрова Александра Сергеевича Руководитель практики
Выделяя действительную1 и мнимую2 части, можем представить относительные ускорения по координатам x и y в виде
Разместите кнопку на своём сайте:
ru.convdocs.org


База данных защищена авторским правом ©ru.convdocs.org 2016
обратиться к администрации
ru.convdocs.org