Разработка линейных программ и их реализация и тестирование в среде программирования Pascal



Скачать 34.48 Kb.
Дата26.07.2014
Размер34.48 Kb.
ТипЛабораторная работа
Лабораторная работа №1

Тема: Разработка линейных программ и их реализация и тестирование в среде программирования Pascal.

ЦЕЛЬ РАБОТЫ: Закрепление знаний об интегрированной среде; составление, ввод и выполнение простейшей линейной программы.

Оборудование: Персональный компьютер.

Программное обеспечение: Borland Turbo Pascal 7.0

  1. ОСНОВНЫЕ СВЕДЕНИЯ

    1. Программы линейной структуры

Алгоритм линейной структуры – это алгоритм, в котором блоки выполняются в указанном порядке, последовательно друг за другом. Программа линейной структуры реализует соответствующий линейный алгоритм.

Чаще всего линейные алгоритмы используются для программирования вычислений по формулам. В этом случае удобно использовать набор встроенных функций Pascal: sin(x) - синус x; cos(x) - косинус x; tan(x)- тангенс x; ln(x) - натуральный логарифм x; exp(x) -показательная функция ex; sqr(x) - квадрат x; sqrt(x) - корень квадратный от х; abs(x) - модуль x.

Для тригонометрических функций аргумент x измеряется в радианах. Гиперболические функции записываются с применением экспоненты, например:

Sh(x)=(exp (x)-exp (-x)) /2



    1. Общие сведения об интегрированной Среде Borland Pascal

Экраны интегрированных Сред Turbo и Borland Pascal подобны и содержат главное меню, окно редактирования, строку состояния. Для входа в главное меню следует нажать F10.

Главное меню содержит пункты: File(Файл), Edit(Редактирование), Search(поиск), Run(Исполнить), Compile(Компиляция), Debug(Отладка), Tools(Инструменты), Options(Параметры), Window(Окно), Help(Помощь). Из этих пунктов для нас важнейшими будут File, Edit, Compile, Run, Help.

В меню File имеются пункты Open (Открыть), при помощи которого открывается существующий программный файл, New (Создать) - создается новый файл, Save (Сохранить) - сохраняется редактируемый файл, Save as (Сохранить как) - файл сохраняется под новым именем, Change dir (Изменить каталог) - задаются входные и выходные каталоги. Последним пунктом нужно пользоваться, чтобы задать ваш каталог, где хранятся тексты программ. Пункт Quit(Выход) служит для выхода из Среды. В меню File приведены также «горячие» клавиши (F3), (F2), (ALT+X) для открытия, сохранения файла и для выхода из Среды соответственно.

В меню Edit имеются пункты Cut (Вырезать), Copy (Копировать), Paste (Вставить), Clear (Очистить), которые служат для вырезания, копирования, вставки и очистки выделенного фрагмента текста, как в любом текстовом редакторе.

Выделение фрагмента текста производится установкой курсора в начале фрагмента, отметкой начала блока (CTRL+K+B), передвижением курсора в конец блока и отметкой конца блока (CTRL+K+K).

Вырезание, копирование, вставка фрагмента осуществляются с помощью пунктов меню Edit или с помощью горячих клавиш (Shift+Del), (CTRL+INS), (Shift+INS) соответственно.

Меню Compile содержит пункт Compile(Компиляция), горячие клавиши ALT+F9.

Меню Run содержит пункт Run(Исполнить), горячие клавиши CTRL+F9.

Меню Help позволяет обратиться к подсказке (справочной системе), содержит пункты Contents (Содержание), Index (Предметный указатель) - горячие клавиши (Shift+F1), Topic search (Тематический поиск) - горячие клавиши (CTRL+F1). Подсказкой следует пользоваться для быстрого освоения Интегрированной Среды. Нажатие клавиши F1 приводит к открытию окна подсказки. Для получения справки о конкретной функции следует установить курсор на любой символ заголовка функции и нажать (CTRL+F1).



  1. ВЫПОЛНЕНИЕ РАБОТЫ



    1. Составьте и выполните программу линейной структуры согласно вариантам заданий.

    2. Введите исходные данные, проверьте полученный результат.

    3. Выполните анализ ошибок, опишите действия по их устранению.

    4. Запишите листинг программы в тетрадь.

Варианты заданий:

Вычислить значение функции трех переменных при заданных значениях параметров:



  1. x=2y+3t- z при y=2; t=5 / (1+y2); z=4

  2. x=3 y2/ (4z-2t2) при t=0.5; z=6; y=t+2z.

  3. x=4y2 /( 4y - 2t3) при t=1 ; z=3; y=t+z.

  4. x=4y3-z / t при t=2; z=3; y=t+z.

  5. x=6 t2- (z+1)/ y2 при y=2; z=4; t=2+z.

  6. x=(8z2+1)/( y +t2) при z=3; t=2; y=3(t+z).

  7. x=6t-3 z2/(y+1) при t=2; z=t+1; y=3.

  8. x=8z / (8 mod (t+z)+2)-y2 при t=1; z=2; y=9 div z.

  9. x=2k2+b-c при y= - 5; k=18 mod 5; b=│y│; c=2b.



  1. ФОРМА ОТЧЕТА

В каждой лабораторной работе отчет должен содержать краткое изложение теории, результат исполнения программ, листинг самостоятельно составленных программ, ответы на вопросы.

  1. КОНТРОЛЬНЫЕ ВОПРОСЫ



  1. Дать определение формального языка, алгоритмического языка, языка программирования.

  2. Классификация языков программирования.

  3. Дать определение трансляции, интерпретации и компиляции.

  4. Структура программы на языке Pascal.

  5. Дать определение величины, переменной, константы.

  6. Оператор присваивания.

  7. Состав среды программирования Turbo Pascal.

  8. Алфавит языка программирования Turbo Pascal.

  9. Типы величин.

Похожие:

Разработка линейных программ и их реализация и тестирование в среде программирования Pascal iconТест «Язык программирования Pascal. Ввод-вывод данных. Ветвление. Циклы»
Какая комбинация клавиш используется для запуска программы на выполнение в среде Turbo Pascal?
Разработка линейных программ и их реализация и тестирование в среде программирования Pascal iconУрок n 17 Основы программирования на языке Turbo Pascal
Паскаль (Pascal)- учебный инструментальный язык программирования вычислительных машин и персональных компьютеров. На современных...
Разработка линейных программ и их реализация и тестирование в среде программирования Pascal iconУрок №57-58 Языки и системы программирования. Начальные сведения о языке Turbo Pascal
...
Разработка линейных программ и их реализация и тестирование в среде программирования Pascal iconИнтегрированная среда программирования Turbo Pascal Язык программирования Pascal
Блеза Паскаля. Первоначально этот язык был создан для обучения программированию. Однако благодаря заложенным в нем большим возможностям...
Разработка линейных программ и их реализация и тестирование в среде программирования Pascal iconБиблиотека для языковых средств программирования
Совместимо с наиболее используемыми сейчас, языками программирования высокого уровня Pascal и C++. Возможно использование в системах,...
Разработка линейных программ и их реализация и тестирование в среде программирования Pascal iconРазработка программных средств автоматизации технических и технологических расчетов в среде Pascal
«Разработка программных средств автоматизации технических и технологических расчетов в среде Pascal»
Разработка линейных программ и их реализация и тестирование в среде программирования Pascal iconКраткая теория по курсу информатика Типы данных языка программирования Turbo Pascal
В языке программирования Turbo Pascal все данные, используемые программой должны принадлежать к какому-либо типу данных. Некоторые...
Разработка линейных программ и их реализация и тестирование в среде программирования Pascal icon«Язык программирования Pascal в примерах»
Предлагаемый курс является введением в программирование на языке Pascal. Его особенность в том, что важнейшие основные понятия программирования:...
Разработка линейных программ и их реализация и тестирование в среде программирования Pascal iconЗадач и упражнений по языку программирования Pascal
Система задач и упражнений по языку программирования Pascal/ Сост. Е. Ю. Жохова, И. Е. Кокорева, П. А. Корнилов, Л. Я. Московская,...
Разработка линейных программ и их реализация и тестирование в среде программирования Pascal iconЛабораторная работа №7 Обработка файлов средствами языка Turbo Pascal
Освоение методики проектирования Pascal-программ с использованием операций с файлами
Разместите кнопку на своём сайте:
ru.convdocs.org


База данных защищена авторским правом ©ru.convdocs.org 2016
обратиться к администрации
ru.convdocs.org