Твердотельное моделирование Содержание Твердотельное моделирование



Скачать 156.92 Kb.
Дата01.12.2012
Размер156.92 Kb.
ТипГлава



Глава 5.

Твердотельное моделирование

Содержание

5. Твердотельное моделирование





5.9.4. Другие полезные советы------------------------------------------------ 5-72

5.1. Обзор процедур твердотельного моделирования

Целью твердотельного моделирования является освобождение пользователя от трудоемкого процесса построения сложной конечно-элементной модели методом прямой генерации. Рассмотрим операции твердотельного моделирования и построения сетки, которые помогают ускорить создание модели.

Построение модели по принципу “снизу-вверх”. Ключевые точки, т.е. точки, которые определяют углы модели, являются геометрическими объектами низшего порядка. Если при построении твердотельной модели прежде всего создаются ключевые точки, а затем они используются для задания объектов более высокого порядка (линий, поверхностей и объемов), то модель строится по принципу “снизу- вверх”.



Рис. 5.1. Конструирование “снизу-вверх”

Построение модели по принципу “сверху - вниз”. Программа ANSYS также предоставляет возможность собрать модель, используя геометрические примитивы, представляющие собой полностью заданные линии, поверхности и объемы. Когда задается геометрический примитив, программа автоматически создает связанные с ним объекты “низшего” уровня,. Если моделирование начинается с построения примитивов более высокого порядка, то говорят, что модель строится по принципу “сверху - вниз”. При моделировании можно произвольно сочетать оба рассмотренных способа.



Рис. 5.2. Конструирование “сверху - вниз” (с помощью примитивов)

Использование булевых операций. Можно получить твердотельную модель, используя операции пересечения, вычитания и другие булевы операции. Булевы операции позволяют работать непосредственно с геометрическими объектами высокого порядка. Оба метода моделирования (“сверху-вниз” и “снизу-вверх”) допускают использование булевых операций.



Рис. 5.3. Создание сложных форм с помощью булевых операций

Повороты изображения и буксировка мышью. Булевы операции, несмотря на удобство их использовании, иногда требуют значительных ресурсов компьютера. В ряде случаев более эффективным может оказаться построение модели с помощью процедур буксировки или поворота.




Рис. 5.4. “Буксировка” поверхности для создания объема [VDRAG]

Перемещение и копирование объектов твердотельных моделей. Повторяющийся фрагмент поверхности или объема сложного вида требуется строить только один раз; затем его можно перемещать, поворачивать и копировать для создания полной модели. Также может оказаться более удобным перенос геометрических примитивов за счет их перемещения, а не изменением рабочей плоскости.

сложная поверхность (блок) при необходимости может быть многократно скопирована (серым цветом)



Рис. 5.5. Копирование поверхности
Построение сетки. Конечная цель при создании твердотельной модели состоит в построении сетки модели вместе с узлами и элементами. Как только построение модели завершено, заданы атрибуты элемента и установлены средства управления качеством сетки, можно предоставить программе ANSYS возможность построить сетку конечных элементов. Выполняя определенные требования, можно задать построение так называемой упорядоченной сетки, которая состоит из четырехугольных элементов или параллелепипедов - “кирпичей”.



Рис. 5.6. Произвольная и упорядоченная сетки

Перемещение и копирование узлов и элементов. Автоматическое построение сетки имеет огромное преимущество перед способом прямой генерации узлов и элементов, но иногда требует чрезмерно много компьютерного времени. Если модель содержит повторяющиеся особенности геометрии, то наиболее эффективным подходом может быть моделирование и построение сетки для области модели и затем создание копий этой области. (Копирование сетки потребует гораздо меньше времени, чем отдельное ее построение для каждого повторяющегося участка.)



Оригинал

Копия

Рис. 5.7. Копирование сеточной области

Нагрузки твердотельной модели. В программе ANSYS нагрузки обычно прикладываются к узлам и элементам. Но при использовании твердотельного моделирования это часто оказывается неудобным. Существует, однако, возможность прикладывать нагрузки непосредственно к твердотельной модели; при инициализации решения (командой SOLVE), программа автоматически перенесет эти нагрузки на конечно-элементную модель.

Правка модели (очистка и удаление). Приступая к исправлению модели, следует руководствоваться иерархией твердотельной модели и конечно-элементных объектов модели. Объект более низкого порядка не может быть удален, если он является частью объекта более высокого порядка. Следовательно, объем не может быть удален, если он имеет сетку конечных элементов, а линию нельзя удалить, если она является частью поверхности, и т.д. Если к объекту приложены нагрузки, то удаление или переопределение этого объекта удаляет приложенные нагрузки из базы данных. Ниже приводится иерархия объектов моделирования:

Наивысшая

Самая низкая

Элементы (и нагрузки элементов)

Узлы (и узловые нагрузки)

Объемы (и нагрузки, приложенные к модели)

Поверхности (и поверхностные нагрузки)

Линии (и нагрузки, приложенные по линии)

Ключевые точки (и сосредоточенные нагрузки)

Если необходимо исправить разбитую на сетку твердотельную модель, обычно требуется сначала удалить все узлы и элементы той части модели, которая будет исправляться, с помощью команд xCLEAR (маршрут меню Main Menu>Preprocessor >Clear). Как только твердотельная модель будет очищена, можно вносить изменения, удаляя (сверху вниз) и задавая геометрические объекты вновь. Как альтернативу процедурам очистки, удаления и переопределения можно иногда использовать непосредственную модификацию ключевых точек:

Команда: KMODIF

Маршрут: Main Menu>Preprocessor>Move / Modify>Set of KPs

Main Menu>Preprocessor>Move / Modify>Single KP

Использование команды KMODIF или соответствующего маршрута меню автоматически очищает и переопределяет присоединенные линии, поверхности и объемы. После внесения изменений в твердотельную модель необходимо снова построить сетку для тех ее областей, которые были очищены.







(а) Исходная сеточная область

(b) Сетка удалена



(с) Модифицированная модель

(d) Модифицированная модель с сеткой

Рис. 5.8. Перестроение твердотельной модели при наличии сетки

5.2. Создание твердотельной модели “снизу - вверх”

Любая твердотельная модель, независимо от способа ее построения (“снизу- вверх” или “сверху - вниз”), состоит из ключевых точек, линий, поверхностей и объемов. Рисунок 5.9 иллюстрирует эти геометрические объекты.



Рис. 5.9. Основные объекты твердотельной модели

Ключевые точки представляют собой вершины твердотельной модели, линии - ребра, поверхности - грани, а объемы - ее внутренние части. Обратите внимание на существование иерархии этих объектов: объем - это объект самого высокого порядка, он ограничен поверхностями, которые в свою очередь ограничены линиями, ограниченными ключевыми точками.

5.2.1. Ключевые точки

Построение модели “снизу-вверх” начинается с задания объектов самого низкого порядка - ключевых точек. Затем можно задать линии, поверхности и объемы, соединяющие эти ключевые точки. При создании объектов более высокого порядка не всегда приходится явно задавать их в порядке возрастания сложности: можно непосредственно построить поверхности и объемы, используя ключевые точки при их вершинах. При этом промежуточные объекты будут созданы автоматически. Например, если некоторый объем определяется восемью угловыми точками, программа автоматически генерирует граничные поверхности и линии.

Задание ключевых точек

В программе ANSYS используются различные способы задания ключевых точек, перечисленные ниже.

  1. Для задания отдельных ключевых точек может использоваться один из следующих способов:

Команда: K

Маршрут: Main Menu>Preprocessor>Create>Keypoints>ln Active CS

Main Menu>Preprocessor>Create>Keypoints>On Working Plane

  1. Для задания ключевых точек в заданном месте существующей линии:

Команда: KL

Маршрут: Main Menu>Preprocessor>Create>Keypoints>On Line

Main Menu>Preprocessor>Create>Keypoints>On Line wlRatio

Генерирование точек из существующих

Располагая созданным при построении модели начальным набором ключевых точек, можно генерировать дополнительные точки с помощью перечисленных ниже способов. (При выполнении большинства булевых операций также создаются ключевые точки.)

  1. Создание ключевой точки между двумя уже существующими:

Команда: KBETW

Маршрут: Main Menu>Preprocessor>Create>Keypoints>KP between KPs

  1. Генерирование нескольких ключевых точек между двумя точками:

Команда: KFILL

Маршрут: Main Menu>Preprocessor>Create>Keypoints>Fill between KPs

  1. Построение ключевой точки в центре дуги окружности, заданной тремя точками:

Команда: KCENTER

Маршрут: Main Menu>Preprocessor>Create>Keypoints>KP at Center

  1. Генерация дополнительных ключевых точек по существующему образцу:

Команда: KGEN

Маршрут: Main Menu>Preprocessor>Copy>Keypoints

  1. Для масштабирования существующего образца ключевых точек используется команда KSCALE. (Прямого доступа к этой команде из графического интерфейса нет.)

  2. Создание набора ключевых точек отражением:

Команда: KSYMM

Маршрут: Main Menu>Preprocessor>Reflect>Keypoints

  1. Перенос ключевых точек в другую систему координат:

Команда: KTRAN
Маршрут: Main Menu>Preprocessorr Move / Modify> Transfer Coord>Keypoints

  1. Для получения предписанного по умолчанию положения незаданных узлов или ключевых точек используется команда SOURCE. (Прямого доступа к этой команде из графического интерфейса нет.)

  2. Вычисление и перемещение ключевой точки в точку пересечения:

Команда: KMOVE

Маршрут: Main Menu>Preprocessor>Move I Modify>To Intersect

  1. Задание ключевой точки в месте расположения существующего узла:

Команда: KNODE

Маршрут: Main Menu>Preprocessor>Create>Keypoints>On Node

Просмотр и удаление точек

Вы можете сохранять точки, используя перечисленные ниже методы:

  1. Распечатка перечня построенных ключевых точек:

Команда: KLIST

Маршрут: Utility Menu>List>Keypoints>Coordinates+Attributes

Utility Menu>List>Keypoints>Coordinates only

Utility Menu>List Picked Entities>Keypoints>Coordinates Only

Utility Menu>Lish Picked Entities>Keypoints>Coords+Attributes

  1. Вывод на экран заданных ключевых точек:

Команда: KPLOT

Маршрут: Utility Menu>Piot>Keypoints

Utility Menu>Plot>Specified Entities>Keypoints

  1. Удаление ключевых точек, не входящих в сетку конечных элементов:

Команда: KDELE

Маршрут: Main Menu>Preprocessor>Delete>Keypoints

Если используется команда /PNUM,KP,1 (маршрут меню Utility Menu> PlotCtrls>Numbering), на экран будут выведены номера тех ключевых точек [с помощью команд LPLOT, APLOT и VPLOT], которые связаны с линиями, поверхностями и объемами.

Команды для ключевых точек, связанных с другими объектами модели

Программа ANSYS предоставляет следующие команды для работы с ключевыми точками.

  1. Вычисление расстояния между точками:

Команда: KDIST

Маршрут: Main Menu>Preprocessor>-Modeling-Operate>KP Distance

  1. Для изменения координат ключевой точки (т.е. перемещения ее в новое положение), используется один из способов, перечисленных ниже. При этом любая сеточная область, связанная с этой ключевой точкой, автоматически очистится, а связанные с заданной точкой объекты более высокого порядка будут переопределены. (Точку также можно переопределить командой K, но только в том случае, если она “свободна”, т.е. не присоединена к линии и не принадлежит сетке.)

Команда: KMODIF

Маршрут: Main Menu>Preprocessor>Move I Modify>Set of KPs

Main Menu>Preprocessor>Move I Modify>Single KP

5.2.2. Линии

Линии в основном используются для построения граничных контуров модели. При построении поверхности или объема порой нет необходимости задавать явно все линии, поскольку во многих случаях программа создает их сама. Задание линий необходимо, если требуется создать линейные элементы (типа балок) или ограничить линиями некоторую поверхность.

Задание линий

В тех случаях, когда требуется задать линию явным образом, используется любой из перечисленных ниже способов.

  1. Задание прямой линии или кубической кривой между двумя заданными ключевыми точками:

Команда: L

Маршрут: Main Menu>Preprocessor>Create>Lines>In Active Coord

  1. Задание дуги окружности, проходящей через три ключевые точки (или через две точки, если задан радиус):

Команда: LARC

Маршрут: Main Menu>Preprocessor>Create>Arcs>By End KPs & Rad

Main Menu>PreprocessomCreate>Arcs>Through 3 KPs

  1. Задание кубической линии из сплайна для набора ключевых точек:

Команда: BSPLIN

Маршрут: Main Menu>PreprocessomCreate>Splines>Spline thru KPs

Main Menu>Preprocessor. Create>Splines>Spline thru Locs

Main Menu>Preprocesson Create>Splines>With Options>Spline thru KPs

Main Menu>Preprocesson Create>Splines>With Options>Spline thru Locs



  1. Задание дуги окружности:

Команда: CIRCLE

Маршрут: Main Menu>Preprocessor>Create>Arcs>By Cent & Radius

Main Menu>Preprocessor>Create>Arcs>Full Circle

  1. Задание линии, состоящей из сегментов сплайна и проходящей через несколько ключевых точек:

Команда: SPLINE

Маршрут: Main Menu>Preprocessor>Create>Splines>Segmented Spline

MainMenu>Preprocessor>Create>Splines>WithOptions>Segmented Spline

  1. Задание прямой линии, проходящей под некоторым углом к другой линии:

Команда: LANG

Маршрут: Main Menu>Preprocessor>Create>Lines>At Angle to Line

Main Menu>Preprocessor>Create>Lines>Normal to Line

  1. Задание линии, проходящей под некоторым углом к двум другим линиям:

Команда: L2ANG

Маршрут: Main Menu>Preprocessor>Create>Lines>Angle to 2 Lines

Main Menu>Preprocessor>Create>Lines>Norm to 2 Lines

  1. Задание линии, примыкающей к концу существующей линии и являющейся касательной к ней:

Команда: LTAN

Маршрут: Main Menu>Preprocessor>Create>Lines>Tangent to Line

  1. Задание линии, касательной к двум линиям:

Команда: L2TAN

Маршрут: Main Menu>Preprocessor>Create>Lines>Tan to 2 Lines

  1. Построение кратчайшей линии между двумя точками на поверхности:

Команда: LAREA

Маршрут: Main Menu>Preprocessor>Create>Lines>Overlaid on Area

  1. Построение линий перемещением набора ключевых точек вдоль некоторой траектории:

Команда: LDRAG

Маршрут: Main Menu>Preprocessor>Operate>Extrude/ Sweep>Along Lines

  1. Построение дуг окружностей поворотом набора ключевых точек относительно некоторой оси:

Команда: LROTAT

Маршрут: Main Menu>Preprocessor>Operate>Extrude / Sweep>About Axis

  1. Построение галтели между двумя пересекающимися линиями:


Команда: LFILLT

Маршрут: Main Menu>Preprocessor>Create>Line Fillet

Действительная форма линии, даже если она задается как “прямая”, будет определяться активной системой координат. Так, например, если в декартовой системе координат производные dX/dL, dY/dL и dZ/dL постоянны вдоль линии (L), то построенная линия будет действительно прямой. В цилиндрической системе координат постоянные значения dR/dL, d/dL и dZ/dL могут соответствовать винтовой линии (если все три компонента не равны нулю).

  1. Построение прямой в независимости от того, какая система координат активна:

Команда: LSTR

Маршрут: Main Menu>Preprocessor>Create>Lines>Straight Line

Генерация линий из существующих

Дополнительные линии могут быть созданы копированием набора существующих линий любым ниже перечисленным способом.

  1. Генерация дополнительных линий:

Команда: LGEN

Маршрут: Main Menu>Preprocessor>Copy>Lines

Main Menu>Preprocessor>Move / Modify>Lines

  1. Симметричное отображение набора:

Команда: LSYMM

Маршрут: Main Menu>Preprocessor>Reflect>Lines

  1. Перенос набора линий в другую систему координат:

Команда: LTRAN

Маршрут: Main Menu>Preprocessor>Move / Ihodify>Transfer Coord> Lines

Модификация линий

Изменить линию можно, переопределив ее командой L или любым из способов.

  1. Деление линии на более короткие части:

Команда: LDIV

Маршрут: Main Menu>Preprocessor>Operate>Divide>Line into 2 Ln's

Main Menu>Preprocessor>Operate>Divide>Line into N Ln's

Main Menu>Preprocessor>Operate>Divide>Lines wl Options

  1. Объединение двух линий:

Команда: LCOMB

Маршрут: Main Menu>Preprocessor>Operate>Add>Lines

  1. Удлинение одного конца линии:

Команда: LEXTND

Маршрут: Main Menu>Preprocessor>Operate>Extend Line

Просмотр и удаление линий

Для просмотра и удаления линий используются перечисленные ниже способы.

  1. Получение перечня линий:

Команда: LLIST

Маршрут: Utility Menu> List>Lines

Utiltiy Menu> List Picked Entities>Lines

  1. Вывод линий на экран:

Команда: LPLOT

Маршрут: Utility Menu>Plot>Lines

Utility Menu>Plot>Specified Entities>Lines

  1. Удаление линий:

Команда: LDELE

Маршрут: Main Menu>Preprocessor>Delete>Line and Below

Main Menu>Preprocessor>Delete>Lines Only

Если используется команда /PNUM,Line,1 (маршрут меню Utility Menu> PlotCtrls>Numbering), на экран будут выведены площади и объемы (при использовании команд APLOT и VPLOT) с пронумерованными линиями.

Замечания

При работе с линиями следует иметь в виду следующее:

  1. Переопределены, изменены или удалены могут быть только линии, которые не принадлежат сеточной области и не присоединены к поверхностям модели. (Команды LDIV, LCOMB и LFILLT дают возможность обойти это правило. Их можно использовать для изменения линий, не принадлежащих сеточной области, даже если они присоединены к поверхности. Присоединенные поверхности будут изменяться, даже если они присоединены к объему модели.)

  2. Для генерации или изменения линий можно использовать некоторые геометрические примитивы и булевы операции.

Похожие:

Твердотельное моделирование Содержание Твердотельное моделирование iconМоделирование и формализация Моделирование как метод познания Моделирование
Моделирование. Человечество в своей деятельности (научной, образовательной, технологической, художественной) постоянно создает и...
Твердотельное моделирование Содержание Твердотельное моделирование iconУчебно-методический комплекс по дисциплине "компьютерное моделирование"
Курс компьютерное моделирование предназначен для подготовки будущих учителей с квалификацией "Учитель информатики и математики" к...
Твердотельное моделирование Содержание Твердотельное моделирование iconМоделирование фро и пф для материалов гексагональной симметрии по набору отдельных ориентаций на so(3)
Целью настоящей работы является моделирование фро в виде отдельных ориентировок, моделирование осуществляется методом цпт-последовательностей...
Твердотельное моделирование Содержание Твердотельное моделирование iconМоделирование систем автоматического регулирования
Моделирование систем автоматического регулирования : методические указания к домашней работе №2 по дисциплине "Моделирование систем"...
Твердотельное моделирование Содержание Твердотельное моделирование iconМатематической моделирование гемодинамики
Специальность 05. 13. 18 математическое моделирование, численные методы и комплексы программ
Твердотельное моделирование Содержание Твердотельное моделирование iconМодели и моделирование систем управления
Моделирование процесс построения условного образа исследуемой системы (процесса, явления)
Твердотельное моделирование Содержание Твердотельное моделирование iconМоделирование динамических систем с гироскопической структурой при параметрических возмущениях
Специальность 05. 13. 18 Математическое моделирование, численные методы и комплексы программ
Твердотельное моделирование Содержание Твердотельное моделирование iconМоделирование многостадийного разрушения и гибели на основе пересечений границ случайными процессами
Специальность: 05. 13. 18 – математическое моделирование, численные методы и комплексы программ
Твердотельное моделирование Содержание Твердотельное моделирование iconНапишите модель и выполните моделирование на интервале 8 часов модельного времени
Задачи по курсу «Имитационное моделирование» для студентов IV курса специальности «Математические методы в экономике»
Твердотельное моделирование Содержание Твердотельное моделирование iconМоделирование процессов пространственной эволюции релятивистских пучков заряженных частиц в газовых средах и внешних полях 05. 13. 18 математическое моделирование, численные алгоритмы и комплексы программ
Моделирование процессов пространственной эволюции релятивистских пучков заряженных
Разместите кнопку на своём сайте:
ru.convdocs.org


База данных защищена авторским правом ©ru.convdocs.org 2016
обратиться к администрации
ru.convdocs.org