Исполнение алгоритма для конкретного исполнителя



Скачать 42.37 Kb.
Дата08.10.2012
Размер42.37 Kb.
ТипДокументы
ГИА 9 класс

А8. Исполнение алгоритма для конкретного исполнителя.


  1. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперед n (где n – целое число), вызывающая передвижение Черепашки на n шагов в направлении движения.

Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись Повтори k [Команда1 Команда2 Команда3] означает, что последовательность команд в скобках повторится k раз.

Черепашке был дан для исполнения следующий алгоритм:

Повтори 10 [Направо 36 Вперед 20 Направо 36]

Какая фигура появится на экране?

1) Правильный пятиугольник

2) Правильный шестиугольник

3) Правильный десятиугольник

4) Незамкнутая ломаная линия


  1. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперед n (где n - целое число), вызывающая передвижение Черепашки на n шагов в направлении движения.

Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись Повтори 5 [Команда1 Команда2] означает, что последовательность команд в скобках повторится 5 раз.

Черепашке был дан для исполнения следующий алгоритм:

Повтори 6 [Вперед 10 Направо 72]

Какая фигура появится на экране?

1) незамкнутая ломаная линия

2) квадрат

3) правильный пятиугольник

4) правильный шестиугольник


  1. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперед n (где n – целое число), вызывающая передвижение Черепашки на n шагов в направлении движения.

Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись Повтори k [Команда1 Команда2 Команда3] означает, что последовательность команд в скобках повторится k раз.

Черепашке был дан для исполнения следующий алгоритм:

Повтори 12 [Направо 45 Вперед 20 Направо 45]

Какая фигура появится на экране?

1) квадрат

2) правильный двенадцатиугольник

3) правильный восьмиугольник

4) незамкнутая ломаная линия


  1. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии.
    В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперед n (где n – целое число), вызывающая передвижение Черепашки на n шагов в направлении движения.

Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись Повтори k [Команда1 Команда2 Команда3] означает, что последовательность команд в скобках повторится k раз.

Черепашке был дан для исполнения следующий алгоритм:

Повтори 4 [Направо 60 Вперед 20 Направо 60]

Какая фигура появится на экране?

1) правильный треугольник

2) квадрат

3) правильный шестиугольник

4) незамкнутая ломаная линия


  1. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперед n (где n – целое число), вызывающая передвижение Черепашки на n шагов в направлении движения.

Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись Повтори k [Команда1 Команда2] означает, что последовательность команд в скобках повторится k раз.

Черепашке был дан для исполнения следующий алгоритм:

Повтори 5 [Вперед 10 Направо 120]

Какая фигура появится на экране?

1) незамкнутая ломаная линия

2) правильный треугольник

3) правильный пятиугольник

4) правильный шестиугольник


  1. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперед n (где n – целое число), вызывающая передвижение Черепашки на n шагов в направлении движения.

Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись Повтори k [Команда1 Команда2] означает, что последовательность команд в скобках повторится k раз.

Черепашке был дан для исполнения следующий алгоритм:

Повтори 6 [Вперед 5 Направо 30]

Какая фигура появится на экране?

1) незамкнутая ломаная линия

2) правильный треугольник

3) правильный пятиугольник

4) правильный шестиугольник


  1. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперед n (где n – целое число), вызывающая передвижение Черепашки на n шагов в направлении движения.

Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись Повтори k [Команда1 Команда2 Команда3] означает, что последовательность команд в скобках повторится k раз.

Черепашке был дан для исполнения следующий алгоритм:

Повтори 3 [Направо 30 Вперед 20 Направо 30]

Какая фигура появится на экране?

1) правильный треугольник

2) квадрат

3) правильный шестиугольник

4) незамкнутая ломаная линия

Похожие:

Исполнение алгоритма для конкретного исполнителя icon1. Величины: константы, переменные, типы величин. Присваивание, ввод и вывод величин. Линейные алгоритмы работы с величинами
Известно, что всякий алгоритм составляется для конкретного исполнителя. В качестве исполнителя мы будем рассматривать компьютер,...
Исполнение алгоритма для конкретного исполнителя iconРешение практической части
Построение алгоритма (основные алгоритмические структуры) и его реализация в среде учебного исполнителя. Демонстрация полученного...
Исполнение алгоритма для конкретного исполнителя iconГиа-9, Часть 2, №14. Запись простого линейного алгоритма для формального исполнителя Задания для тренировки егэ-2007 (В3)
Выполняя первую из них, Калькулятор прибавляет к числу на экране 2, а выполняя вторую, утраивает его. Запишите порядок команд в программе...
Исполнение алгоритма для конкретного исполнителя iconГенетические алгоритмы
Основными параметрами конкретного алгоритма являются размер популяции и вероятности применения операторов. Первоначально по содержанию...
Исполнение алгоритма для конкретного исполнителя iconПонятие алгоритма, его свойства, логические теории алгоритмов
Алгоритм может представлять собой некоторую последовательность вычислений, а может последовательность действий нематематического...
Исполнение алгоритма для конкретного исполнителя iconСравнительный анализ модификаций алгоритма муравья
Показано, что начальные параметры алгоритма (количество феромона, видимость, коэффициент испарения) существенно влияют на результат...
Исполнение алгоритма для конкретного исполнителя iconЛекция содержит фундаментальные понятия машинных алгоритмов и их использование для проектирования программного обеспечения
Машина состояний. Блок-схема алгоритма (бса). Матричная структура алгоритма (мса). Строка Тьюринга. Строка Маркова. Строка Ляпунова....
Исполнение алгоритма для конкретного исполнителя iconНейронных сетей на основе комбинирования информационных технологий
Предложена модификация комбинированного алгоритма обучения многослойного персептрона, позволяющая с помощью алгоритма имитации отжига...
Исполнение алгоритма для конкретного исполнителя iconЭкзаменационные требования для абитуриентов I. Исполнение сольной программы
Экзаменационная комиссия может вводить в качестве дополнительного раздела экзамена исполнение гамм и арпеджио
Исполнение алгоритма для конкретного исполнителя iconТема: Алгоритм, свойства алгоритма.
Понятие алгоритма так же фундаментально для информатики, как и понятие информации
Разместите кнопку на своём сайте:
ru.convdocs.org


База данных защищена авторским правом ©ru.convdocs.org 2016
обратиться к администрации
ru.convdocs.org